The week in review.

20 hours.

Yes, I know I’m supposed to keep track of this on a daily basis, but I really didn’t get a lot significant done until today, just little bits and pieces here and there, tasks taking less time than actually making one of these blog entries. Even so, the last month has been a wash. The EFIS was in the shop, work went crazy on me and I had to go out of town for a few days on a pre-planned vacation, and I just flat out lost my mojo. Let me tell you, working all through Memorial Day weekend sucks big time, and I haven’t had to do that in years, even in production. But now with two working knees, and all the fiddly bits I’ve needed finally coming together, I’m in a good place. It all started with a good shop cleaning. A couple of weeks ago, I hung up the control surfaces on the walls, in an attempt to de-clutter the work area, and this worked out brilliantly, so much so that I can actually test the trim wiring with the elevator hanging on the wall near the tail. But the workbench was a blast zone. Shipping materials alone accounted for a good half of the mess, tools and hardware the other half. Yesterday I put things away and recycled boxes and got most of my workspace back. Then it was all about knocking down all the dominoes I’d been setting up for myself over the last couple of months.

At one point I got the control stick wiring all done, thinning out the bundle in the big blue casing so I could actually work with it. Here I am, happily wiring away, combining all the ground wires into one, reducing the bundle of wires from 17 to 10. This is wrong. More on that later.

The replacement pax stick came in, and I managed to cut it and drill it without incident, but I’ve come to the conclusion that working with steel sucks. I’ve been picking little slivers of steel out of my hide for two weeks now.

When we got back from vacation in Yellowstone, I found a package from Infinity Aerospace waiting for me: my 3-circuit relay deck, which handles 2 axes of trim and flaps. Here it is being fitted for a stand so it can sit in between the middle seat ribs:

It also included the spacer necessary to fit the Infinity stick grip to a 7/8″ tube, which is the OD of the pax stick. Here’s the pax stick installed temporarily, and you can see the terminal block betwen the two ribs.

Yesterday was a ton of work aimed primarily at having a lot fewer little half-done tasks laying about adding to that feeling of frustration. First on the list is something that’s been bugging me for two months: the AHRS mount. I dragooned Shelley into helping me for a bit, first we did the dimpling for the relay deck hardware, then the rest of the dimpling for the AHRS mount. This thing has a LOT of rivets along the bottom. The dimpling’s done, but the rivets aren’t, and that was on my list to finish, but it got pushed in favor of actually finishing some other things that have been nagging at me for a while. Here’s the AHRS mount, nestled near the floor, creating a level spot for the SP2 and SP4 sensors:

In the pic, you can see the sensors fastened to standoffs on the mount platform, with DB9 connectors coming out of them. Originally, I had the ribbon cable supplied by MGL, but mounting the single connector with the ribbon cable was awkward and the longer ribbon cable I made (after a long-ass drive to the Valley) didn’t fire up both sensors, so I just made each one its own DB9 connector. The MGL-supplied ones had RCA audio connectors for data, which didn’t sit too well with me, so now I have proper crimped connections on both sensors. I still need to dress and secure the wire bundle a little bit, but it’s working pretty well.

This morning I had intended to finish that process, as well as do some other things in the back of the plane, like install the TNC terminal on the cable for the Garmin GPS antenna. Of course I screwed up the terminal pin, so I had to replace it, somehow. It was an amazing SoCal day, so I took the Buell, went to Fry’s and got my TNC and BNC connectors. funny thing though. RG58 connectors don’t work on RG400 cable. The center conductor is too thick to fit in the pin housing and the ferrule is too small to go over the insulation and leave enough room to get the connector body between the braid and the center insulator. Mouser to the rescue. Apparently the type needed are RG142/RG400 terminals. ACS sells these bad boys for $38 a pop, but Mouser has them for $7.95. I also got a bunch of BNC connectors for the backplate-side connections. The only thing is, you have to slog through Mouser’s online catalog, which blows chunks, at least until you light up the enhanced catalog, which is like an interactive version of their PDF catalog. That’s easy to figure out. I also took the opportunity to order a threaded CPC (circular plastic connector) for the pax stick disconnect.

This pic shows two DB9 connectors attached to the MGL Com Extender. These are the connectors for the Trio Gold Standard Autopilot servos.

I finished up the connectors and ran power, and guess what? The autopilot servo works. There’s a menu in the EFIS, where you select your AP mode, and which servo is connected to what port. Another menu is testing and diagnostics. I can report that the pitch servo definitely does what the test suite asks it to do. This is one of the reasons I didn’t get the AHRS mount riveted (plus Shelley was baking bread, and I can’t ask her to buck rivets when there’s bread in the works). This also meant I had to wire the AP panel switch as well, which I’d been putting off. It is now DONE!

I also got the backup instrument going, a MGL AV-2.

It has an artificial horizon, compass, and turn coordinator, so if the EFIS ever packs up, I have that to fall back on. It’s using the same sensors as the EFIS, but the rate of failure on the SP2/SP4 combo is so low as to be almost statistically impossible.

Remember when I said, regarding the stick wiring, “this is wrong?” This is why.

I put ring terminals on the pilot stick wires and attached them all to the terminal block, then tested them all with a multimeter just to make sure I had contact on all the switches. I’m glad I did. Every switch beeped except the thumb-operated flaps-up. The reason for this is that stupidly, I wired the flaps-up wire into the bundle with the grounds. I have no idea why, total brain fart. Maybe I thought the black/red wire was a ground of some kind for that switch. Fortunately, I saved all the excess wire from the bundle-thinning operation and was able to salvage the red-and-black wire that I’d cut off. I spliced it back in, and now I have redo the double-layer of shrinkwrap, put on new ring terminals, and reinstall.

But I feel pretty good about this week.. I think I can get the flaps and trim wired up, and be pretty much done with control wiring, assuming I can figure out how to make the start buttons on the stick work the starter.

Comments (1)

  1. 4:51 pm, June 28, 2011Uncle Bill  / Reply

    John, no updates in almost a month; I was ready to send out the Mounties. We be glad your back. You mentioned Shelly was baking bread and it triggered a memory. When I was a kid It was a great treat to come home to find that my aunt Aysalee was visiting and was baking bread. I would tear off a chunk still warm slather it in butter and assend into Bread Heaven.

    Uncle Bill

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.